Cisco Packet Tracer 7.x tutorials

Packet Tracer 7.3 - IP telephony basic configuration

3.719512195122 1 1 1 1 1 Rating 3.72 (82 Votes)

Tutorial description

This tutorial is designed to help you to configure the voice over ip (voip) features available in Packet Tracer 7.3

It will show you the steps required to :

  • Configure Call Manager ExpressTM on a 2811 router,
  • Use the various telephony devices
  • Setup dial peers
  • Connect  CiscoTM IP phones as well as analogue phone on the network.

Network diagram

VOIP tutorial network diagram

Note : Connect only IP Phone 1 at the beginning of the lab. IP Phone 2 must be disconnected.

 

Tasks 1 : Configure interface FastEthernet 0/0 and DHCP server on RouterA (2811 router)

Configure the FastEthernet 0/0 interface with 192.168.10.1/24 ip address. Don't forget to enable the interface with the no shutdown command !

RouterA>enable
RouterA#configure terminal
RouterA(config)#interface FastEthernet0/0
RouterA(config-if)#ip address 192.168.10.1 255.255.255.0
RouterA(config-if)#no shutdown

 

The DHCP server is needed to provide each IP phone connected to the network with an IP adress and the TFTP server location.

RouterA(config)#ip dhcp pool VOICE #Create DHCP pool named VOICE
RouterA(dhcp-config)#network 192.168.10.0 255.255.255.0 #DHCP network network 192.168.10 with /24 mask#
RouterA(dhcp-config)#default-router 192.168.10.1 #The default router IP address#
RouterA(dhcp-config)#option 150 ip 192.168.10.1 #Mandatory for voip configuration.

 

After configuring the ISR router, wait a moment  and check that ‘IP Phone 1’ has received an IP address by placing your cursor over the phone until a configuration summary appears.

 

Tasks 2 : Configure the Call Manager Express telephony service on RouterA

You must now configure the Call Manager Express telephony service on RouterA  to enable voip on your network.

RouterA(config)#telephony-service #Configuring the router for telephony services#
RouterA(config-telephony)#max-dn 5 #Define the maximum number of directory numbers#
RouterA(config-telephony)#max-ephones 5 #Define the maximum number of phones#
RouterA(config-telephony)#ip source-address 192.168.10.1 port 2000 #IP Address source#
RouterA(config-telephony)#auto assign 4 to 6 #Automatically assigning ext numbers to buttons#
RouterA(config-telephony)#auto assign 1 to 5 #Automatically assigning ext numbers to buttons#

 

Task 4 : Configure a voice vlan on SwitchA

Apply the following configuration on SwitchA interfaces. This configuration will separate voice and data traffic in different vlans on SwitchA. data packets will be carried on the access vlan.

SwitchA(config)#interface range fa0/1 – 5 #Configure interface range#
SwitchA(config-if-range)#switchport mode access
SwitchA(config-if-range)#switchport voice vlan 1 #Define the VLAN on which voice packets will be handled#

 

Task 5 : Configure the phone directory for IP Phone 1

Although ‘IP Phone 1’ is already connected to SwitchA, it needs additionnal configuration before beeing able to communicate. You need to configure RouterA CME to assign a phone number to this IP phone.

RouterA(config)#ephone-dn 1 #Defining the first directory entry#
RouterA(config-ephone-dn)#number 54001 #Assign the phone number to this entry#

 

Task 5 : Verify the configuration

Ensure that the IP Phone receives an IP Address and a the phone number 54001 from RouterA  (this can take a short while).

IP Phone number 1 confgured with IP address and phone number

IP Phone 1 configured - Front view

Task 6 : Configure the phone directory for IP Phone 2

Connect IP Phone 2 to SwitchA and power the phone ON using the power adapter (Physical tab).

RouterA(config)#ephone-dn 2 #Defining the first directory entry#
RouterA(config-ephone-dn)#number 54002 #Assign the phone number to this entry#

 

Task 7 : Verify the configuration

Ensure that the IP Phone 2 receives an IP Address and a the phone number 54002 from RouterA  (this can take a short while). Same procedure as task n°5.

Dial 54001 and check if IP phone 1 correctly receives the call.

Packet Tracer 7.3 - IP telephony advanced configuration

3.9090909090909 1 1 1 1 1 Rating 3.91 (22 Votes)

Tutorial description

This tutorial will guide you for advanced voip configuration in Cisco Packet Tracer 7.3 network simulation software.  Based on the Cisco's Hierarchical Network Design Model, this simulated network has voip call routing features enabled between two campus buildings with network services (DNS, DHCP ...) centralized in the datacenter.

In a real world environment, the CUCME router would also be located in the datacenter. However, Packet Tracer doesn't seems to support this configuration as IP phones don't register and receive a valid phone number.

 

Network diagram

Packet Tracer 5.3 - Small business voip configuration

Download lab (Packet Tracer >= 6.2)

 

Configuration tasks

CME-3 configuration

IP configuration

hostname CME-3
!
interface FastEthernet0/0
 ip address 192.168.69.254 255.255.255.0
 duplex auto
 speed auto
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.69.1 
!

Telephony service configuration

telephony-service
 max-ephones 5
 max-dn 5
 ip source-address 192.168.69.254 port 2000
 auto assign 4 to 6
 auto assign 1 to 5

Ephone declaration and number assignment

ephone-dn 1
 number 2001
!
ephone-dn 2
 number 2002
!
ephone 1
 device-security-mode none
 mac-address 0090.0C57.C85E
 type 7960
!
ephone 2
 device-security-mode none
 mac-address 0090.0C20.BA20
 type 7960
!
ephone 3
 device-security-mode none
 mac-address 0005.5E9E.2AC5
 type 7960
 button 1:2
!
ephone 4
 device-security-mode none
 mac-address 0060.5C2D.6220
 type 7960
 button 1:1

 

CME configuration

IP configuration

hostname CME
!
interface FastEthernet0/1
 ip address 192.168.65.3 255.255.255.0
 duplex auto
 speed auto
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.69.1 
!

Telephony service configuration

 telephony-service
  max-ephones 42
  max-dn 144
  ip source-address 192.168.65.3 port 2000
  auto assign 4 to 6
  auto assign 1 to 5

Ephone declaration and number assignment

 ephone-dn 1
 number 1101
!
ephone-dn 2
 number 1102
!
ephone-dn 3
 number 1103
!
ephone-dn 4
 number 1104
!
ephone-dn 5
 number 1105
!
ephone-dn 6
 number 1106
!
ephone 1
 device-security-mode none
 mac-address 0090.0C57.C85E
 type 7960
 button 1:1
!
ephone 2
 device-security-mode none
 mac-address 0090.0C20.BA20
 type 7960
 button 1:2
!
ephone 3
 device-security-mode none
 mac-address 00E0.A340.E430
 type 7960
 button 1:3
!
ephone 4
 device-security-mode none
 mac-address 0060.4710.AE01
 type 7960
 button 1:4
!
ephone 5
 device-security-mode none
 mac-address 000C.8521.0C20
 type 7960
 button 1:5
!
ephone 6
 device-security-mode none
 mac-address 00D0.D31A.7EE9
 type CIPC
 button 1:6

 

Call routing configuration between CME routers

Dial peers are used to identify call source and destination endpoints and to define the characteristics applied between two CME routers. The destination pattern, configured in a dial peer by using the destination-pattern command, associates a dialed string with a specific telephony device. If the dialed string matches the destination pattern, the call is routed to the remote dial peers. You have to configure a destination pattern for each voice-network dial peer that you define on your network routers.

The destination pattern can be either a complete telephone number or a partial telephone number with wildcard digits, represented by a period (.) character. Each "." represents a wildcard for an individual digit that the originating router expects to match. For example, if the destination pattern for a dial peer is defined as "555....", then any dialed string beginning with 555, plus at least four additional digits, matches this dial peer.

 

CME-3 dial-peer configuration

dial-peer voice 1 voip
 destination-pattern 1...
 session target ipv4:192.168.65.254
!

CME dial-peer configuration

dial-peer voice 2 voip
 destination-pattern 2...
 session target ipv4:192.168.69.254
!

Packet Tracer 7.2.2 - Precision Time Protocol

2.7857142857143 1 1 1 1 1 Rating 2.79 (14 Votes)

What is Precision Time Protocol (PTP) ?

Precision Time Protocol (P2P) is a feature of Packet Tracer 7.2.2 available in IE2000 industrial switches.

This time synchronization protocol is defined in IEEE-1588 as Precision Clock Synchronization for Networked Measurements and Control Systems, and was developed to synchronize the clocks in networks devices that include distributed device clocks with various levels of precision and stability. Acurate time synchronization is vital for smart grid power automation applications such as virtual power generators and peak-hour billing, but also for network outage monitoring tools which require a high level of time accuracy and stability.

 

PTP configuration in Packet Tracer 7.2.2

Precision Time protocol can be simulated in Packet Tracer 7.2.2 using IE2000 switches. These switches features three PTP modes :

  • boundary
  • end-to-end transparent
  • forward.
Switch(config)#ptp mode ?
  boundary        Boundary Clock mode
  e2etransparent  End-to-End Transparent Clock mode
  forward         Forward packets without processing

 

1.Configure PTP using the following commands

Switch(config)#ptp mode boundary 
Switch(config)#interface fastEthernet 1/1
Switch(config-if)#ptp enable 

Read more ...

Packet Tracer 7.2.2 - Video tutorials

3.6153846153846 1 1 1 1 1 Rating 3.62 (52 Votes)

Introduction

Cisco Packet Tracer 7.2.2 is a powerful simulation software for CCNA and CCNP certification exam training. The video tutorials provided in this sections will help you to understand the basics of Packet Tracer 7.2.2 operations (tutorial 1) and how the simulation mode works to get a deep analysis of packet flow between network devices (tutorial 2).

Video tutorial 3 provides an advanced network configuration example using Packet Tracer 7.2.2 in a VOIP lab scenario.

 

Tutorial 1 - Basic network configuratio

This first video demonstrates basic use of Packet Tracer 7.2.1. It will show you how to configure IP services on a Cisco ISR router and a workstation in the CiscoTM Packet Tracer 7.2.1 network simulation software :

  • IP address configuration
  • Connection to a router using a crossover cable
  • Initial configuration of the router and the workstation

 

You can configure the workstation's global and interface settings on the Config tab.

The Desktop tab provides additional tools to configure workstation dial-up settings, IP settings, use a terminal window, open a host command line interface, open a web browser, configure LinksysTM wireless settings, establish a VPN connection, generate network frames, and issue SNMP requests to network devices.

 

 

Tutorial 2 -Following packets

This second video tutorial shows how Packet Tracer can capture and display the content of packet as they go through the network (simulation mode). Features are similar to an advanced network tracking software and allows monitoring of frames as they go through and are processed by network devices. The network monitoring tools are available in Packet Tracer simulation mode.

 

 

Tutorial 3 - Configure Cisco Call Manager Express (CME)

This advanced Packet Tracer 7.2.1 video tutorial explains the different options available in Cisco Packet Tracer for Call Manager Express (CME) configuration on a Cisco 2811 ISR router.

 

Legal

Video tutorial extracted from Youtube. Extract of youtube terms of service :

8.1 When you upload or post Content to YouTube, you grant:

  1. to YouTube, a worldwide, non-exclusive, royalty-free, transferable licence (with right to sub-licence) to use, reproduce, distribute, prepare derivative works of, display, and perform that Content in connection with the provision of the Service and otherwise in connection with the provision of the Service and YouTube's business, including without limitation for promoting and redistributing part or all of the Service (and derivative works thereof) in any media formats [and through any media channels];
  2. to each user of the Service, a worldwide, non-exclusive, royalty-free licence to access your Content through the Service, and to use, reproduce, distribute, prepare derivative works of, display and perform such Content to the extent permitted by the functionality of the Service and under these Terms.

 

Packet Tracer 7.2.1 - IP telephony devices

3.9444444444444 1 1 1 1 1 Rating 3.94 (18 Votes)

Supported devices in Packet Tracer 7.2.1

Cisco Packet Tracer 7.2.1 supports three telephony devices :

  • Cisco 7960 IP Phone
  • Home VOIP device for analog phone connection to an IP network.
  • Cisco IP Communicator software on desktop or laptop PC

 

Cisco 7960 IP Phone

Cisco 7960 emulated IP phone in Packet Tracer - Front view

 

Power up the phone

Two options are available in Packet Tracer for powering up the 7960 IP Phone :

  • External power adapter
  • PoE (only with 3560 multilayer switch)

If you choose to use the external power adapter, go to the physical tab and drag and drop the "IP_PHONE_POWER_ADAPTER" to the bottom left connector of the 7960 IP Phone.

Cisco 7960 emulated IP phone in Packet Tracer - Back view

 

If you want to use the PoE functionnality of the Cisco 3560 switch, apply the following configuration to the switch interface connected to the phone :

Switch(config)#int fastEthernet 0/1
Switch(config-if)#power inline auto

  

Place calls with 7960 IP Phone

The 7960 IP Phone emulated in Packet Tracer 7.2.1does not have any configurable options. It receives it's IP address through DHCP and it's line number from the Call Manager Express server.

 In the GUI tab, you can place a call, answer a call, and send Do, Re, and Mi notes to the recipient phone. To place a call enter the recipient's line number first using the keypad and then click on the handset to dial out.

To answer a phone call on the analog phone, click on the handset when the phone is ringing. While the line is connected, you can send Do, Re, or Mi to the recipient by pressing the respective buttons. In order to hear the sounds, be sure Sound is enabled in Preferences. To end a call, click on the handset.

 

Home VOIP device

Packet Tracer 7.2.1 - Home VOIP device

The Home VoIP only has a "Server Address" configuration in which you have to place the Call Manager Express IP address.

 

Cisco IP Communicator software

The IP Communicator software is installed on desktop or laptop end devices. Configure the computer for DHCP address assignment and use the "Desktop" tab to access the IP Communicator software. The software will receive it's phone line number from the Cisco Call Manager Express server.

Packet Tracer 7.2.1 - Applications available on a laptop device.

To place a phone call, enter the number of the recipient phone using the keypad and then click the Dial button. Once the recipient has answered the call, the status message will indicate that the Cisco IP Communicator is connected and a green light will show. While the call is still active, click on the Do, Re, or Mi buttons to send the respective sounds to the recipient. To end the call, click the EndCall button. For the best possible experience while making calls, be sure that Sound is enabled in Preferences.

If you want configure the Cisco IP Communicator to use a different TFTP server from the default TFTP server, follow these steps. On the upper right-hand corner of the Cisco IP Communicator GUI, there are four buttons above the words "Cisco IP Phone." Click on the first button from the left to open a context menu and then select Preferences. Select the option Use these TFTP Servers: and then enter the IP address of the TFTP server that you wish to use.

Packet Tracer 7.2.1 - IP Communicator software