Cisco Packet Tracer 7.x labs

Lab 12 - PPP

3.4117647058824 1 1 1 1 1 Rating 3.41 (17 Votes)

Introduction

PPP is a non-proprietary WAN data-link layer encapsulation protocol which can be viewed as an enhancement of HDLC as it embeds many additional features when compared with HDLC:

  • PPP Authentication. Supported authentication protocols are PAP and CHAO
  • Compression
  • Error detection
  • Multilink to provide load-balancing over multiple network interfaces

 

Network diagram

Packet Tracer 5.3 - PPP configuration lab network diagram

 

Lab instructions

This lab will test your ability to configure PPP on a serial link in Packet Tracer 7.1. Practicing this labs will help you to better understand what is a DCE, a DTE, and aclock rates on a serial router interconnection and make you ready for the CCNA ppp labs and simlets.

1. Use the connected laptops to find the DCE and DTE routers. You can connect to the routers using CLI.

2. Configure the routers with the following parameters :

- Clock : 250000
- PPP link between the routers
- DCE IP : 192.168.10.5/30

- DTE IP : 192.168.10.6/30

3. Check IP connectivity between the two routers using the ping command.

 

Lab solution

1. Use the connected laptops to find the DCE and DTE routers

The show controllers <serial interface> command is used to determine which side of the cable is the DCE side.

In this example, Router-A is the DTE side, and Router-B the DCE side (DCE V.35, clock rate set).

Router-A#show controllers serial 0/0/0
Interface Serial0/0/0
Hardware is PowerQUICC MPC860
DTE V.35 TX and RX clocks detected

Router-B#show controllers serial 0/0/0
Interface Serial0/0/0
Hardware is PowerQUICC MPC860
DCE V.35, clock rate 2000000

2. Configure the routers with the following parameters

Router-B beeing the DCE, clock rate has to be configured on Router-B serial 0/0/0 interface

Router-B(config)#interface serial 0/0/0
Router-B(config-if)#clock rate 250000

 

Then, configure PPP encapsulation and IP address on Router-B serial 0/0/0 interface. The encapsulation ppp configures PPP protocol on the serial interface. PPP authenication can be oprtionnally configured using the following IOS commands which are not used in this lab :

  • ppp authentication : Set PPP link authentication method
  • ppp pap:  Set PAP authentication parameters

Router-B beeing the DCE side of the serial link, the 192.168.10.5/30 IP address is configured on Router-B serial 0/0/0 interface. Don't forget to enable the interface with a no shutdown command.

Router-B(config)#interface serial 0/0/0
Router-B(config-if)#encapsulation ppp
Router-B(config-if)#ip address 192.168.10.5 255.255.255.252
Router-B(config-if)#no shutdown

 

The show interfaces serial 0/0/0 confirms that PPP encapsulation is enabled on the interface : Encapsulation PPP, loopback not set, keepalive set (10 sec)

Router-B#show interfaces serial 0/0/0
Serial0/0/0 is up, line protocol is up (connected)
  Hardware is HD64570
  Internet address is 192.168.10.5/30
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, loopback not set, keepalive set (10 sec)
  Last input never, output never, output hang never
  [...]

 

Finally, configure PPP encapsulation and IP address on Router-A serial 0/0/0 interface. The link becomes up as both routers are correctly configured.

Router-A(config)#interface serial 0/0/0
Router-A(config-if)#encapsulation ppp
Router-A(config-if)#ip address 192.168.10.6 255.255.255.252
Router-A(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

 

3. Check IP connectivity between the two routers using the ping command.

Issue a ping from Router-A to Router-B to test network connectivity between the two routers.

Router-A#ping 192.168.10.5

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 3/3/4 ms

 

Lab 11 - HDLC

3.3846153846154 1 1 1 1 1 Rating 3.38 (13 Votes)

Introduction

HDLC is a data link protocol used on synchronous serial data links. Because the standardized HDLC cannot support multiple protocols on a single link (lack of a mechanism to indicate which protocol is carried), Cisco developped a proprietary version of HDLC, called cHDLC, with a proprietary field acting as a protocol field. This field makes it possible for a single serial link to accommodate multiple network-layer protocols.

Cisco’s HDLC is a point-to-point protocol that can only be used on serial links or leased lines between two Cisco devices. PPP has to be used when communicating with non-Cisco devices. HDLC is the default encapsulation on serial links in a Cisco router. However, to change the encapsulation back to HDLC from PPP, use the following command from interface configuration mode:

Router(config-if)#encapsulation hdlc

With a back-to-back serial connection, the ISR router connected to the DCE end of the serial cable provides the clock signal for the serial link. This clock is received by the DTE device. The clock rate command in the interface configuration mode enables the router at the DCE end of the cable to provide the clock signal for the serial link. The default clock rate is 64000.

 

Read more ...

Lab 6 - Basic router setup

2.7924528301887 1 1 1 1 1 Rating 2.79 (53 Votes)

Introduction

At the first boot of a Cisco ISR router, some basic configuration has to be performed to secure adminitrative access to the router. This lab will test your ability to configure the basic security settngs of a Cisco ISR router and help you to get ready for the router configuration simulation activities in the CCENT / ICND1 certification exam (Chapter 5.0 Infrastructure Maintenance of Cisco Certified Entry Networking Technician (CCENT) exam)

Read more ...

Lab 4 - Port security

2.9047619047619 1 1 1 1 1 Rating 2.90 (63 Votes)

Introduction

A growing challenge for network administrators is to be able to control who is allowed - and who isn't - to access the organization's internal network. This access control is mandatory for critical infrastructure protection in your network. It is not on public parts of the network where guest users should be able to connect.

Port security is a feature implemented in Cisco Catalyst switches which helps network engineers in implementing network security on network boundaries.

In its most basic form, the Port Security feature remembers the MAC address of the device connected to the switch edge port and allows only that MAC address to be active on that port. If any other MAC address is detected on that port, port security feature shutdown the switch port.

The switch can be configured to send a SNMP trap to a network monitoring solution to alert that a port is disabled for security reasons.

 

Read more ...

Lab 3 - VLAN and VTP configuration

3.3522727272727 1 1 1 1 1 Rating 3.35 (88 Votes)

Network diagram

The aim of this lab is to test your ability to configure VLAN and VTP on a small network of 4 switches using Packet Tracer 7.2.1.

This lab will help you to prepare the VTP testlet and simlet questions of the Cisco ICND1 exam.

 

Lab instructions

1.Configure the VTP-SERVER switch as a VTP server

2.Connect to the 3 other switches and configure them as VTP clients.
All links between swiches must be configured as trunk lines.

3.Configure VTP domain name as "TESTDOMAIN" and VTP password as "cisco"

4.Configure VLAN 10 with name "STUDENTS" and VLAN 50 with name "SERVERS"

5. Check propagation on all switches of the VTP domain.

 

VLAN and VTP lab solution

1. Configure the VTP-SERVER switch as a VTP server

VTP-SERVER(config)#vtp mode server

Verify the VTP operating mode using the show vtp status command

VTP-SERVER#show vtp status
VTP Version                     : 2
Configuration Revision          : 4
Maximum VLANs supported locally : 255
Number of existing VLANs        : 7
VTP Operating Mode              : Server
VTP Domain Name                 : TESTDOMAIN
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0xAE 0x4F 0x3F 0xC5 0xD3 0x41 0x9C 0x11
Configuration last modified by 192.168.1.1 at 3-1-93 00:27:41
Local updater ID is 192.168.1.1 on interface Vl1 (lowest numbered VLAN interface found)

 
2. Connect to the 3 other Catalyst switches and configure them as VTP clients.
All links between swiches must be configured as trunk lines.

VTP-CLIENT3(config)#vtp mode client

VTP-CLIENT3(config)#vtp mode client

Verify the VTP operating mode of the switch using the show vtp status command. The "VTP Operating Mode" shoud have the"Client" value. Example with VTP-CLIENT3 switch is provided below.

VTP-CLIENT3#sh vtp status
VTP Version                     : 2
Configuration Revision          : 4
Maximum VLANs supported locally : 255
Number of existing VLANs        : 7
VTP Operating Mode              : Client
VTP Domain Name                 : TESTDOMAIN
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0xAE 0x4F 0x3F 0xC5 0xD3 0x41 0x9C 0x11
Configuration last modified by 192.168.1.1 at 3-1-93 00:27:41

 
Configure each link between switches as a trunk line using the switchport mode truink command

interface GigabitEthernet1/1
switchport mode trunk

interface GigabitEthernet1/2
switchport mode trunk

 

3. Configure VTP domain name as "TESTDOMAIN" and VTP password as "cisco"

On the VTP server Catalyst switch:

VTP-SERVER(config)#vtp domain TESTDOMAIN
VTP-SERVER(config)#vtp password cisco

On each VTP client switch :

VTP-CLIENT1(config)#vtp password cisco
VTP-CLIENT1(config)#vtp domain TESTDOMAIN

 
4. Configure VLAN 10 with name "STUDENTS" and VLAN 50 with name "SERVERS"

On the VTP server Catalyst 2960 switch, configure the following commands to create both "STUDENTS" and "SERVERS" vlans :

VTP-SERVER(config)#vlan 10
VTP-SERVER(config-vlan)#name STUDENTS
VTP-SERVER(config)#vlan 50
VTP-SERVER(config-vlan)#name SERVERS

 
5. Check propagation of both "STUDENTS" and "SERVERS" vlans on all Catalyst 2960 network switches of the VTP domain.

Use the show vlan brief on each switch to check propagation of the 2 VLANS.

VTP-SERVER#show vlan brief

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4, [...]
10   STUDENTS                         active    
50   SERVERS                          active    
1002 fddi-default                     active    
1003 token-ring-default               active    
1004 fddinet-default                  active    
1005 trnet-default                    active



Published by Packet Tracer Network.