Packet Tracer 7.2.1 available for download

2.9285714285714 1 1 1 1 1 Rating 2.93 (28 Votes)

Cisco Packet Tracer 7.2.2 has been released ! Current build is Packet Tracer 7.2.2.0418. Have a look on Cisco Packet Tracer 7.2.2 new features.

Cisco Packet Tracer 7.2.1 has ben released on December 28th, 2018 with version number 7.2.1.0218 and is now available for download on Cisco Netacad website. Cisco Packet Tracer 7.2.1 is a maintenance release for Cisco Packet Tracer 7.2 correcting various issues, removing the netacad login requirement at each Packet Tracer launch. However, Netacad login is still required after each PC boot. This behavior is reported as normal by Cisco Packet Tracer development team on https://www.ptnetacad.net/bugzilla/show_bug.cgi?id=22990

Update 05/09/2019 : Cisco updated Netacad and Packet Tracer 7.2.1 login to make it use the Cisco OneID Identity Provider. Password required to login in Packet Tracer might have changed if you had multiple Cisco accounts linked to the same email address. 

 Cisco Packet Tracer 7.2.1 available for download

Download Cisco Packet Tracer 7.2.1

A new build of Cisco Packet Tracer 7.2.1 (build 222) is under active development and should be released soon. This new build will resolve some crashh issues described at the end of the page.

Cisco Packet Tracer 7.2.1 new features

As Cisco Packet Tracer 7.2.1 is a maintenance release, no new feature has been added to this version.

Refer to What's new in Packet Tracer 7.2 ? page for Cisco Packet Tracer 7.2 family new features :

  • New workspace theme
  • Meraki Server
  • Meraki Security Appliance
  • Home Router
  • ASA 5506-X firewall
  • PPPoE
  • 802.1x
  • Connection to real network using TCP server or websocket
  • [...]

Cisco Packet Tracer 7.2.1 is officially supported on Microsoft Windows 7,Windows 8.1, Windows 10, Ubuntu 14.04 LTS, and MacOS.

Cisco Packet Tracer 7.2.1 is not officially supported on Ubuntu 18.04. Manual installation of libpng12 is required to make Cisco Packet Tracer 7.2.1 work on Ubuntu 18.04 .

Cisco Packet Tracer 7.2.1 supports activities files (PKT / PKA) created with previous Packet Tracer 7.1 7.0, 6.3, 6.2, 6.1.1, 6.0.1 and 5.X. All activities provided in the Cisco CCNA Routing & Switching, CCNA Discovery, CCNA Exploration, CCNA Security, and IT Essentials curricula are compatible with Packet Tracer 7.2.1. However, new files created with Cisco Packet Tracer 7.2.1 can't be used in previous versions.

Login to Cisco Packet Tracer 7.2.1

Cisco Packet Tracer 7.2.1 requires a valid Cisco Networking Academy login for unrestricted use. Otherwise, Cisco Packet Tracer limits the number of times that files can be saved to ten times.

Logging in removes all usage restrictions. There is no limit on the number of machines that an account can be logged into

 

Bugfixes

The following Cisco Packet Tracer 7.2 bugs are fixed in Cisco Packet Tracer 7.2.1 :

  • [Fixed in Cisco Packet Tracer 7.2.1] The Cisco Netacad credentials are required at each application startup.

Known issues

Cisco Packet Tracer 7.2.1 might consistently crashing when configuring interfaces or when deleting links. The issue will be corrected in the upcoming Cisco Packet Tracer 7.2.1 build 222 .

One way CHAP authentication might fail in Cisco Packet Tracer 7.2.1 . The feature is reported functional in Cisco Packet Tracer 7.2.0