Packet Tracer 7.2 - Tips for CCNP SWITCH exam preparation

2.4285714285714 1 1 1 1 1 Rating 2.43 (7 Votes)

CCNP SWITCH exam

CCNP SWITCH certifies the  planning, configuring, and verifying the implementation of complex enterprise switching solutions that use the Cisco Enterprise Campus Architecture.

CCNP SWITCH exam number is 300-115. Exam duration is 120 minutes with 30-40 questions including labs and simlets.

A valid CCNA certification is required before taking CCNP SWITCH.

Packet Tracer 7.2 features for CCNP SWITCH exam preparation

The following content describes, for each CCNP SWITCH exam topic, the features supported in Cisco Packet Tracer 7.2 and the IOS commands available for labs and simlets preparation.

Cisco has been improving Packet Tracer support for CCNP exam since Packet Tracer 7.0. Packet Tracer 7.2 now support wired 802.1x (dot1x) authentication but dos not support VTP v3 or VTP pruning which are expected in a future release.

1.1 Configure and verify switch administration

SDM templates

SDM templates are not supported in Packet Tracer

Managing MAC address table

Static mac address configuration, mac addresstable lookup, and mac address table clearing are supported in Packet Tracer.

Mac address table can be reviewed globally, by interface, for static or dynamic entries only.

Switch#show mac address-table 
          Mac Address Table
-------------------------------------------

Vlan    Mac Address       Type        Ports
----    -----------       --------    -----

   1    0001.63c7.1d72    DYNAMIC     Fa0/1
   1    0001.64b5.c6d0    DYNAMIC     Fa0/3
   1    00d0.bcb2.9699    DYNAMIC     Fa0/2

Switch#show mac address-table ?
  dynamic     dynamic entry type
  interfaces  interface entry type
  static      static entry type
  <cr>

Switch(config)#mac address-table static ?
  H.H.H  48 bit mac address

Switch#clear mac address-table ?
  dynamic  dynamic entry type
  <cr>

Troubleshoot Err-disable recovery

 Err-disable is not supported in Packet Tracer.

1.2 Configure and verify Layer 2 protocols

CDP, LLDP

CDP and LLDP discovery protocols are both supported in Packet Tracer 7.2 on all Cisco Catalyst switches and ISR routers emulated devices. Both protocols can be enabled or disabled globally or per interface.

Packet Tracer CDP capabilities

Router#show cdp neighbors 
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone
Device ID    Local Intrfce   Holdtme    Capability   Platform    Port ID
Switch       Gig 0/0          162            S       2960        Fas 0/1

Router(config)#cdp ?
  run  Enable CDP

Router(config)#interface  gigabitEthernet 0/0
Router(config-if)#cdp ?
  enable  Enable CDP on interface

Packet Tracer LLDP capabilities

Switch#show lldp neighbors 
Capability codes:
    (R) Router, (B) Bridge, (T) Telephone, (C) DOCSIS Cable Device
    (W) WLAN Access Point, (P) Repeater, (S) Station, (O) Other
Device ID           Local Intf     Hold-time  Capability      Port ID
Router              Fa0/1          120        R               Gig0/0

Total entries displayed: 1

Switch(config)#lldp ?
  run  Enable LLDP

Switch(config)#interface fastEthernet 0/1
Switch(config-if)#lldp ?
  receive   Enable LLDP reception on interface
  transmit  Enable LLDP transmission on interface

 

UDLD

UDLD protocol is not supported in Packet Tracer.

 

1.3 Configure and verify VLANs

Access ports

Access port configuration is supported in Packet Tracer with switchport mode access & switchport access vlan commands

VLAN database

VLAN database is supported in Packet Tracer on Catalyt 3650-24PS Multilayer switch. However, configuring VLAN in the vlan database mode is deprecated. VLAN have now to be configured from config mode (configure terminal).

Switch#vlan ?
  database  Configure VLAN database
Switch#vlan database 
% Warning: It is recommended to configure VLAN from config mode,
  as VLAN database mode is being deprecated. Please consult user
  documentation for configuring VTP/VLAN in config mode.

Normal, extended VLAN, voice VLAN

Normal VLAN (1 to 1005) and extended VLAN range (1006 to 4094) are supported on Catalyst 2960.

Switch(config)#vlan ?
  <1-4094>  ISL VLAN IDs 1-1005

Voice VLAN configuration is supported on Catalyst switches

Switch(config-if)#switchport voice vlan ?
  <1-4094>  Vlan for voice traffic

 

1.4 Configure and verify trunking

VTPv1, VTPv2, VTPv3, VTP pruning

VTP v1 and VTP v2 are supported in Packet Tracer in client, server, transparent mode on Catalyst switches. VTP domain can be configured an propagated through switches.

Switch(config)#vtp ?
  domain    Set the name of the VTP administrative domain.
  mode      Configure VTP device mode
  password  Set the password for the VTP administrative domain
  version   Set the adminstrative domain to VTP version

Switch(config)#vtp version ?
  <1-2>  Set the adminstrative domain VTP version number

Switch(config)#vtp mode ?
  client       Set the device to client mode.
  server       Set the device to server mode.
  transparent  Set the device to transparent mode.

VTP v3 and VTP pruning are not supported in Cisco Packet Tracer 7.2 (expected in a future version)

dot1Q

Dot1Q (802.1Q) is supported in Packet Tracer with the switchport trunk encapsulation dot1q command on Catalyt 3650-24PS Multilayer switch.

Switch(config-if)#switchport trunk encapsulation ?
  dot1q  Interface uses only 802.1q trunking encapsulation when trunking

Native VLAN

Native VLAN is supported in Packet Tracer with the switchport trunk native vlan command.

Switch(config-if)#switchport trunk native vlan ?
  <1-4094>  VLAN ID of the native VLAN when this port is in trunking mode

Manual pruning

Manual VLAN pruning is supported in Packet Tracer with the switchport trunk allowed vlan command.

Switch(config-if)#switchport trunk allowed vlan ?
  WORD    VLAN IDs of the allowed VLANs when this port is in trunking mode
  add     add VLANs to the current list
  all     all VLANs
  except  all VLANs except the following
  none    no VLANs
  remove  remove VLANs from the current list
Switch(config)#interface fastEthernet 0/1
Switch(config-if)#switchport mode trunk  
Switch(config-if)#switchport trunk allowed vlan 10,11,12

 

1.5 Configure and verify EtherChannels

LACP, PAgP, manual

LACP and PAgP etherchannel protocol are supported on all Catalyst switches in Packet Tracer 7.2 through the channel-protocol IOS command.

Switch(config-if)#channel-protocol ?
  lacp  Prepare interface for LACP protocol
  pagp  Prepare interface for PAgP protocol

Layer 2, Layer 3

Etherchannel can be configured on both layer 2 (switchport) or layer 3 (no switchport) interfaces on multilayer catalyst switches

  • Load balancing
  • EtherChannel misconfiguration guard

 

1.6 Configure and verify spanning tree

  • PVST+, RPVST+, MST
  • Switch priority, port priority, path cost, STP timers
  • PortFast, BPDUguard, BPDUfilter
  • Loopguard and Rootguard

 

1.7 Configure and verify other LAN switching technologies

SPAN, RSPAN

SPAN and RSPAN are supported in Packet Tracer with the monitor session commands. SPAN and RSPAN can be configured on Catalyst switches, including multilayer switches.

Switch(config)#monitor session 1 ?
  destination  SPAN destination configuration
  source       SPAN source configuration

Switch(config)#monitor session 1 destination ?
  interface  SPAN source or destination interface
  remote     RSPAN

 

1.8 Describe chassis virtualization and aggregation technologies

Stackwise

Stackwise function of Catalyst switches is not supported in Cisco Packet Tracer

 

2.1 Configure and verify switch security features

  • DHCP snooping
  • IP Source Guard
  • Dynamic ARP inspection
  • Port security
  • Private VLAN
  • Storm control

802.1x authentication

Wired 802.1x (dot1x) authentication support has been added in Packet Tracer 7.2. All the required IOS commands for CCNP switch exam have been added in Packet Tracer.

Warning : dot1x commands are only supported in IOS15. Update switch IOS to IOS15 (image available on TFTP server) before starting dot1x configuration

Switch(config)#aaa authentication ?
  dot1x   Set authentication lists for IEEE 802.1x.
  enable  Set authentication lists for enable.
  login   Set authentication lists for logins.
  ppp     Set authentication lists for ppp.

Dot1x configuration example on a Catalyst 2960, c2960-lanbasek9-mz.150-2.SE4.bin image

aaa new-model
!
aaa authentication dot1x default group radius 
!
dot1x system-auth-control
!
interface Vlan10
 mac-address 000c.cfb1.ce02
 ip address 192.168.10.1 255.255.255.0
!
radius-server host 192.168.10.3 auth-port 1645 key radius

interface FastEthernet0/1
 switchport mode access
 switchport nonegotiate
 no cdp enable
 authentication port-control auto
 dot1x pae authenticator
!

2.2 Describe device security using Cisco IOS AAA with TACACS+ and RADIUS

  • AAA with TACACS+ and RADIUS
  • Local privilege authorization fallback

3.1 Configure and verify first-hop redundancy protocols

HSRP

HSRP is supported on IOS routers and multilayer switches with standby commands in Packet Tracer.

HSRP priority levels, preemption and object tracking are also supported.

Switch(config-if)#standby 1 ?
  ip        Enable HSRP and set the virtual IP address
  ipv6      Enable HSRP IPv6
  preempt   Overthrow lower priority Active routers
  priority  Priority level
  timers    Hello and hold timers
  track     Priority Tracking

VRRP

VRRP is not supported in Packet Tracer

GLBP

GLBP is not supported in Packet Tracer