Packet Tracer Blog

Report a Packet Tracer 7.2 bug

4.5 1 1 1 1 1 Rating 4.50 (2 Votes)

Cisco Packet Tracer 7.2 bugs can be reported to Packet Tracer development team on Netacad bugzilla (https://www.ptnetacad.net/bugzilla/bugzilla-login.php).

A list of most frequently reported bugs is provided by the team at https://www.ptnetacad.net/bugzilla/duplicates.cgi. Please check that list before submitting a new issue and submit clear and recise issues following the Cisco Packet Tracer Bug Writing Guidelines.

Bug reporting interface for Cisco Packet Tracer 7.x

Packet Tracer 7.0 build 202 released !

4.2619047619048 1 1 1 1 1 Rating 4.26 (84 Votes)

Packet Tracer 7.0 build 202 has been released on 17 June 2016. This new Packet Tracer version, which has been under active testing for 6 month, is the first Packet Tracer release including Internet of Everything features linked with the CCNA Industrial exam (CCNA IMINS2). This new version is expected to fix an OpenSSL vulnerability affecting multiple Cisco products (bug CSCuy54539 for Packet Tracer 6.x) but no confirmation has been issued for the moment.

An IoE (Internet of Everything) tab has been added to the server device. Three new Cisco routers and an IE2000 industrial switch were also added. Packet Tracer 7.0 features a lot of new protocols (LLDP, PTP, ...) and bug correction. As Packet Tracer 6.3, a Netacad account is required to access to the software. However, everyone is now able create a Netacad account, download Packet Tracer 7.0 for free, and get an introduction to Packet Tracer. Packet Tracer 7.0 new features.This is a very good news for CCNA self learners preparing the simulation questions of the CCNA exam !!

 

Leaked information (unconfirmed) in the last 6 month

Wireless IoE devices could also be added to this future Packet Tracer 7 version but no détails have leaked for the moment. Packet Tracer 7.0 could also provide Smart Cities scenarios with wireless connected cars. A lot of testing happened on Smart Cities features at the end of July but the development team seems to hava quite a lot of remaining crash problems.

CCNP Preparation : VIRL simulator

3.1428571428571 1 1 1 1 1 Rating 3.14 (14 Votes)

A virtual version of the Cisco Nexus 9000 datacenter switch is now available for CCNP Datacenter training : Nexus 9000v (or NX-OSv 9000) switch. All the Nexus 9000 features are supported except the following table :

NX-OS Features

Limitations

QoS

Not supported on NX-OSv 9000.

BFD

Not supported on NX-OSv 9000.

ACL

Not supported on NX-OSv 9000.

Policy maps

Not supported on NX-OSv 9000.

ARP Suppression

Not supported on NX-OSv 9000.

SPAN

Not supported on NX-OSv 9000.

IGMP Snooping

Not supported on NX-OSv 9000.

AMT

Not supported on NX-OSv 9000.

LISP

Not supported on NX-OSv 9000.

OTV

Not supported on NX-OSv 9000.

Nexus 7000 Titanium NX-OS simulator has been included by Cisco in their new VIRL (Virtual Internet Routing Lab) simulation platform. Compared to Packet Tracer  VIRL uses real cisco IOS, IOS-XR, NX-OS images running in virtual environments. The NX-OS simulation platform is now named NX-OSv and features a Nexus 7000 switch running NX-OX v7.2 . NX-OSv can be used in GNS3 labs and linked to other Cisco devices like CSR1000V or other vendors simulated devices. This new simulation environment will help students preparing CCNA datacenter or CCNP by overcoming Packet Tracer limitations.

VLAN management on Cisco ISR routers

5 1 1 1 1 1 Rating 5.00 (3 Votes)

VLAN management is quite different on ISR routers than on Catalyst switches. VLAN can be used as 802.1q subinterfaces for routed interfaces or with a switch-like configuration on Ethernet Switch Modules (HWIC-4ESW for example)

Subinterface configuration (routed interfaces)

Layer 3 router interfaces cannot be configured in switch mode using "switchport" command on a Cisco ISR router. However, 802.1q trunks interconnexion is supported on these interfaces using the subinterface feature.

Virtual layer 3 interfaces are bound to the physical port using the interface <interface name>.<inderface id> command, <interface id> beeing the subinterface ID. For better configuration readability, the <interface id> is usually configured with the <vlan id> value. The encapsulation dot1Q <vlan id> maps the trafic flowing with the 802.1q vlan id (tagged) to the subinterface.

In the example below, FastEthernet0/0.20 is a subinterface bound to the FastEthernet0/0 physical interface. FastEthernet 0/0.20 is configured to process trafic flowing on vlan 20 in the 802.1q trunk connected to the FastEthernet 0/0 physical router interface.

interface FastEthernet0/0.20
  encapsulation dot1Q 20
  ip address 10.20.10.1 255.255.255.0

interface FastEthernet0/0.30
  encapsulation dot1Q 30
  ip address 10.30.10.1 255.255.255.0

VLAN database (ESW module)

If an EtherSwitch Service Module (HWIC-4ESW for example) has been installed on the ISR router, VLAN for that module can be configured using the vlan database in Packet Tracer 7.2. Port membership to the vlan is configured in the same way than on a Catalyst switch using the "switchport access vlan <vid>" commmand.

Read more ...

Zone based firewalling in Cisco Packet Tracer

4 1 1 1 1 1 Rating 4.00 (15 Votes)

Zone based firewalling is available in Cisco Packet Tracer 2800 routers with IOS 12.4(15)T1 and in new 2901/2911 ISR routers with IOS 15.1(4). This feature was introduced by Cisco in IOS 12.4(6)release.

The zone-member command seems to be only available on 2811 router's FastEthernet interfaces. It is not available on vlan interfaces of this router or in a 2911 router.

Configuration example:

class-map type inspect match-all all-private
 match access-group 101
!         
policy-map type inspect priv-pub-pmap
 class type inspect all-private
  inspect
 class class-default
!
zone security public
zone security private

zone-pair security priv-pub source private destination public
 service-policy type inspect priv-pub-pmap
! 
interface FastEthernet0/0
 ip address 192.168.110.44 255.255.255.0
 zone-member security public
!